Always consult the official Owners Manuals first!

Difference between revisions of "Editors"

From Fractal Audio Wiki
Jump to navigation Jump to search
(9 intermediate revisions by the same user not shown)
Line 551: Line 551:
 
=Working with presets=
 
=Working with presets=
  
==Preset menu entries==
+
==Preset menu==
  
 
Commands in the Preset menu:
 
Commands in the Preset menu:
Line 622: Line 622:
 
Exporting presets can also be accomplished in Manage Presets. When exporting from Manage Presets, the preset number will be added to the start of the filenames on disk and the preset title.
 
Exporting presets can also be accomplished in Manage Presets. When exporting from Manage Presets, the preset number will be added to the start of the filenames on disk and the preset title.
  
==Preset+Cab bundles==
+
==Preset+Cab bundle==
  
 
A Preset+Cab bundle contains one preset plus any User Cab Impulse Responses (IRs) used by that preset. Bundles make it easier to share sounds and are easy to export and import.
 
A Preset+Cab bundle contains one preset plus any User Cab Impulse Responses (IRs) used by that preset. Bundles make it easier to share sounds and are easy to export and import.
Line 764: Line 764:
  
 
[[image:FC-126side-by-side.jpg|400px|link=]]
 
[[image:FC-126side-by-side.jpg|400px|link=]]
 +
 +
=Keyboard shortcuts=
 +
 +
'''Presets'''<BR>
 +
Preset Manager = Command/Control + M<BR>
 +
Preset Picker = P<BR>
 +
Preset up/down = Command/Control + PgUp / PgDn (on a MacBook: hold Fn too)<BR>
 +
Refresh preset = F5<BR>
 +
Save preset = Command/Control + S<BR>
 +
Save preset to new preset number = Shift + Command/Control + S<BR>
 +
Revert preset = Shift + Command/Control + F12<BR>
 +
Clear preset = Shift + Command/Control + Backspace<BR>
 +
Save snapshot = Shift + Control (Alt) + Command/Control + S<BR>
 +
Import preset = Shift + Control (Alt) + Command/Control + I<BR>
 +
Export preset = Shift + Control (Alt) + Command/Control + X<BR>
 +
 +
'''Scenes'''<BR>
 +
Select a scene = Command/Control + 1/2/3/4/5/6/7/8
 +
 +
'''Blocks'''<BR>
 +
Show Block Info = Alt or F1<BR>
 +
Show Quick Build panel = Q<BR>
 +
Insert a shunt = Command/Control + U<BR>
 +
Bypass or engage the selected block, or toggle X/Y (old editors) = Spacebar<BR>
 +
Set state of block across all scenes to engage = Shift + Spacebar<BR>
 +
Set state of block across all scenes to bypass = Shift + Command/Control + Spacebar<BR>
 +
Disconnect all cables from selected block = Command/Control + D<BR>
 +
Delete block = Backspace<BR>
 +
Open the Edit field of the selected control = Enter<BR>
 +
Display the menu associated with the ‘+’ button on the selected dropdown control = +<BR>
 +
Toggle the “Global” button for the selected control = G<BR>
 +
Value up/down = cursor up/down<BR>
 +
Save block to Block Library = Command/Control + B<BR>
 +
 +
'''Channels'''<BR>
 +
Select channel (E and F apply to the MUX block only) = A/B/C/D/E/F<BR>
 +
Next channel = X<BR>
 +
Reset channel = Command/Control + I<BR>
 +
 +
'''Tuner'''<BR>
 +
Command/Control + T<BR>
 +
 +
'''Devices'''
 +
Show devices = Command/Control + K
 +
 +
'''Communications'''<BR>
 +
F8: pause communications<BR>
 +
 +
'''Preferences'''<BR>
 +
Command/Control + P<BR>
 +
 +
'''Undo, Redo'''<BR>
 +
Undo = Command/Control + Z<BR>
 +
Redo = Command/Control + Y<BR>
 +
Cut, copy, paste = Command/Control + X/C/V<BR>
 +
 +
'''Preset Manager, Cab Manager'''<BR>
 +
Manage Presets = Command/Control + M<BR>
 +
Manage Cabs = Shift + Command/Control + M<BR>
 +
 +
'''Grid Navigation Mode'''<BR>
 +
Shift + Command/Control + G<BR>
 +
 +
'''Window size'''<BR>
 +
Full screen = Shift + Command/Control + W<BR>
 +
Normal size = Shift + W
  
 
=FAQ=
 
=FAQ=

Revision as of 21:26, 25 April 2022

Editor.png

Software editors

Official editors for Windows and Mac

Axe-Edit III, FM3-Edit and FM9-Edit are the software editors for Fractal Audio's Axe-Fx III, FM3 and FM9 guitar processors.

Download the latest versions here

System requirements:

  • Mac OS 10.7 or newer (Intel or M1 processors)
  • Windows 7 or newer (32-bit or 64-bit)

Notes:

  • Starting with firmware 19.06 for the Axe-Fx III, Axe-Edit III 1.11.00 (or greater) is required to communicate with the Axe-Fx III. Previous versions of Axe-Edit III will not work with firmware 19.06 or greater. Axe-Edit III 1.11.00 (or greater) will work with previous firmware version 3.02 and greater.
  • On Windows computers, Fractal Audio's USB driver has to be installed first. Download here
  • If you get an error message about a missing file MSVCP140.dll, install the MS Visual C++ Redistributable Update.
  • Older versions of the editors can be downloaded from the unofficial archive.

Editing on a tablet or smartphone

Ipad.jpg FracPad.jpg

Currently there are no official editors available from Fractal Audio for iOS or Android tablets and smartphones. Alternative options:

  • Extend the computer screen to a separate tablet (wired or wireless) using tools built in the OS, or a software utility such as Duet Display (Mac/iOS), or a combined hardware+software solution such as Luna Display. This lets you move the editor screen to the tablet and use its touchscreen for editing.
  • Run FracPad, forum member AlGrenadine's mobile app for Fractal Audio's processors. It runs on Android and iOS devices. It's not officially supported by Fractal Audio.
  • Use wireless MIDI connections with Macs and Windows PCs, with the computer acting as the interface between the app on the tablet or phone and the Fractal Audio device. More information

FracTool

Forum member AlGrenadine's FracTool for Windows and Mac offers functionality not provided by the official editors.

Install and connect

Install

The installer is packaged in a .zip (Win) or .dmg (Mac) archive file. Double-click the file and follow the on-screen instructions.

Release Notes are included with each installer download. Read them! They include information about new features, changes, and what you should be aware of before updating and using the new version. Release notes are also displayed after installation and can be found under Help | View Release Notes.

Releasenotes.png

Click on the top-left program logo, or select Help | About to see the installed version.

Connect

Usb.png

The software editors depend on USB 2.0 (or greater) to connect to the hardware. Operation without an USB connection to the guitar processor is NOT supported (no offline editing). The connection uses the USB-B port on the hardware (not the USB-A port on the FM3).

On Windows computers, Fractal Audio's USB driver has to be installed first. Download USB drivers for Windows

To confirm that the editor is communicating with your Axe-Fx II, look for a green check mark with the word Connected in the upper left corner of the program window. If the message does not appear, don’t panic. Go to Settings | Preferences to select the ports of the device, or read the Troubleshooting section below.

The editor relies on intensive two-way communication which can cause audio gaps or stutters when operating the guitar processor through its onboard user interface or through a foot controller like the Fractal Audio Systems FC-6 and FC-12. The Pause communications button in the upper left corner puts communications on hold so you can test performance without glitches. Alternatively, select the equivalent command in the Settings menu, or press the F8 key on your keyboard.

The editor can control multiple guitar processors of the same type. Click Tools | Show Available Devices to see which connected devices are detected and available. The dialog box provides Scan and Test options.

Tip: when using a USB-C to USB-A adapter on a newer Apple computer, plug the USB-C adapter into a the port on the Mac first, allow it several seconds to “wake up” and then connect a USB cable and the unit into the adapter.

Startup processes

Refresh definitions

When you first launch the editor, or for the first time after having updated your guitar processor’s firmware, the editor will likely need to refresh the information it has stored locally about the device, the so-called “definitions”. The editor detects such changes and will start the refresh process automatically. The process may run for a while.

You can manually force the editor to re-read block definitions by selecting Settings | Refresh After New Firmware or Settings | Preferences | Refresh.

Note: installing beta versions of firmware will NOT trigger the automatic refresh process, so you'll have to do that manually.

Automatic updates

At startup, the editor checks automatically if an official update for the editor is available and if so, offers the option to download and install the update. This process can be disabled in Settings | Preferences | Options. You can also click Help | Check for Updates. Or download the latest version of the editor manually from Support.

Preset and cab names

Also, at each startup the editor will fetch all Presets names and Cab names from the guitar processor. This ensures that the editor and the guitar processor are in sync. You can disable this in Settings | Preferences | Options. When disabled, you can still refresh Preset and Cab names manually by pressing the Refresh icon in so-called “picker” windows (explained later).

Troubleshooting

Fractal-Bot.png GoogleChrome.jpg Logic.jpg

Running Fractal-Bot and a software editor at the same time can cause conflicts. Try to avoid this.

The editor should generally detect your guitar processor and connect automatically. If a problem occurs, you will see a “Disconnected” indicator (above the program logo) or a warning indicating Communication failure unable to complete the communication request due to time-out. Steps to resolve possible connection issues:

  • Try manually setting or re-setting the two ports under Settings | Preferences | Ports.
  • Ensure that your guitar processor is connected via USB.
  • If your guitar processor has multiple USB ports, ensure that you’re using the USB Type B port on the guitar processor.
  • If using Windows: Verify that you’ve installed the latest drivers. Verify the installed drivers in Windows’ Control Panel.
  • The editor requires compatible firmware running on the Fractal Audio Systems guitar processor. The version of the installed firmware of the connected guitar processor is displayed in the top-left area of the editor window.
  • Reboot! Shut down the editor, shut down your device, and shut down your computer. Re-start your computer, power on your device, and re-start the editor.
  • Ensure that your guitar processor is connected directly to your computer, rather than through a USB hub or cable extender. A REAR panel USB port on the computer is sometimes preferable as front panel ports may utilize an integrated USB hub. Also, try a different USB port or different USB cable.
  • If using Windows, try right-clicking the editor’s shortcut icon and choosing Run as Administrator.
  • Try the following steps to reset your port selections:
    1. Power on your guitar processor.
    2. Launch the editor and go to Settings | Preferences.
    3. Set both ports to NONE.
    4. Close the Preferences dialog and quit the editor.
    5. Re-launch the editor.
    6. Open Settings | Preferences and select the appropriate ports. You should see a green “check” next to each port selection.
    7. Close the dialog. The editor should now communicate with the hardware.

Apple's energy saving options in some Macs can cause issues like dropped USB connections after waking up. Set them at default in System Preferences.

Google Chrome can cause issues with older editors.

"There is a known issue with Chrome seizing MIDI ports (both physical and virtual MIDI-over-USB ports) as part of some misguided MIDI over the internet idea. Since the AX-8 is USB 1.1 it only allows one connection so if Chrome grabs it then AX-8 Edit won't be able to use it. Unfortunately Google seems uninterested in fixing it." [1]

"Chrome definitely can hijack the MIDI over USB port on the AX8. When that happens, it's not enough to just close the browser, you have to ensure that it is not running in the background. Fractal Audio has tested and confirmed this." [2]

If you're experiencing issues running the Axe-Fx III, Axe-Edit III and Apple Logic, read this for a solution.

Explaining the editor window

The editor’s window can be scaled by dragging a border. Select Settings | View to snap the editor to Normal Size or Full Screen. Note that the editor has a fixed width/height ratio, so the editor may not fill your computer’s entire display in Full Screen mode.

Top

Top.png

Many of the controls and commands described below have keyboard shortcuts.

Pause Communications
See above.

Program logo
Displays the version of the installed editor.

Connected
Shows if the editor is connected to the hardware, and shows the version of the firmware installed on the guitar processor.

Name
If you have given the guitar processor a custom name in Setup | Config, that name will appear in the upper left corner.

Scenes
Press one of the numbered buttons at the top to select a Scene. Or select a Scene from a dropdown menu, or scroll through Scenes using the “+/-“ buttons. The name of the scene is displayed next to the dropdown menu, where it can be renamed too.

Presets
Select a Preset from a dropdown menu next to the preset name. Or scroll through Presets using the “+/-“ buttons. The number and name of the preset are displayed next to the dropdown menu, where it can be renamed too.

Preset name
Once a preset is loaded in the editor, its name is displayed and its contents are displayed on the grid — the structure where blocks are placed and interconnected. The current scene name is displayed too.

Snapshot
Create a Snapshot, or use its dropdown menu to show the Snapshot folder contents, clear the list or load a Snapshot.

Save
Save the preset. The yellow LED lits when changes to the preset have not yet been saved.

Setup
Enter the Setup menu to set global parameters for the guitar processor, including audio I/O, Global EQ, USB levels and more.

Tuner
Displays the Tuner.

Tap
Tap to set the Tempo.

BPM
Shows the Tempo of the current preset in BPM (Beats Per Minute).

CPU
Shows the current CPU usage as a number and meter. When the CPU usage exceeds a threshold, a red “Warning” message is displayed here.

Controllers
Configure Internal Controllers, Scene Controllers and Tempo settings. Set the state of Control Switches per scene. See where Modifiers are being used. Read more about these functions in the guitar processor’s Owner’s Manuals.

Quick Build
This lets you insert a block from a graphical interface.

Block Infobutton
Changes the way blocks are displayed on the grid. By default, the full name and the block instance are shown. Pressing Block Info (or holding ALT) will abbreviate the block name, show the active channel and show Global Blocks.

Scene Mgr
Scene Manager lets you set the state of blocks across scenes, (re)name scenes, copy and swap scenes, etc.

Perform
Configure the Performance pages, globally as well as per preset.

(i)
Shows the currently being used Amp Type(s) and Amplifier block channel(s).

10
Configures Preset and Scene names to mask characters that do not fit on the scribble strips of the foot switches.

FC Edit
Configure the onboard switches of the FM3 and FM9, and the FC foot controllers.

FC Per-Prst
Same as above, but this applies to the current preset only.

Sets/Songs
Create songs and sets for use with an FC controller. Axe-Fx III only.

Middle

The lay-out grid (middle section) shows the layout of the preset (blocks). Click any block on the grid to display its settings in the editor area, below the grid.

Middle.png

Bottom

The editor area (bottom) displays either the names of the scenes, or block parameters and controls.

If there's no block selected (empty block), this area shows the names of all 8 scenes. Click on a number to switch scenes. Double-click the scene name to rename the scene. Note: this list disappears when a block is selected on the grid. Click on an empty spot on the grid to show the list again.

Scenenames.png

Click on a effect block to display parameters and controls.

Left.png Block.png

The icon at the left shows the name of the currently viewed or edited block.

Channel
This lets you select a channel of the currently selected block and lets you manage channels through its dropdown menu.

Type
When supported by a block, this lets you select a specific type of the effect. This acts as a kind of super parameter, and changing it can cause other parameters to appear, disappear or change their values.

Library
This menu lets you save blocks and channels to your personal library on disk, recall them at will, and provides other functions.

Global Block
Link, load and unlink blocks as Global Blocks. Only available in Axe-Edit.

Explaining the user interface controls

The various knobs, sliders, dropdowns and switches are used to control sound parameters in the guitar processor. Changes are heard in real time while you work. Note that stuttering or light clicking can occasionally be heard while you adjust certain parameters.

Knobs:

  • Click a knob and drag up/right to increase, or down/left to decrease. Fastest response is obtained with 45° Northeast/Southwest motion. Hold ⌘ (Mac) or CTRL (Win) key for finer mouse resolution.
  • The default knob mode is LINEAR. You can momentarily invoke CIRCULAR knob mode by holding the ALT key. You can also change the default knob mode under Settings | Preferences | General.
  • Double-click the knob or its label to set a generic default value. Important: Generic knob values will not necessarily be the same as those obtained when you reset an entire block, change its type, etc.
  • Scroll (mouse wheel, trackpad, etc.) over a knob to edit parameter values. Hold ⌘ (Mac) or CTRL (Win) key for fine resolution, giving each wheel click has the same precise action as a single “tick” of the VALUE wheel on the guitar processor. The UP and DOWN arrow keys are equivalent to using the mouse scroll wheel.

Faders:

  • Click and drag the fader handle. Double-click, wheel and arrow keys work the same as when operating a knob.

Switches:

  • Click the switch. Double-click the label to set it to a default value (see above). Some switches may disengage automatically.

Dropdown menus:

  • Click the text area of the dropdown to display a list of all options. Double-click the label to set a generic default. Click the UP/DOWN arrows to select the previous or next value. Tip: Turn any dropdown menu into a picker window (see below) by holding SHIFT and clicking the dropdown control.

Picker windows:

  • This is a special selection window presented when a dropdown would be too small for the available options. Picker windows normally close once you click a selection. Tip: Turn any dropdown menu into a picker window (see below) by holding SHIFT and clicking the dropdown control.
  • Use the “Pushpin” button in the upper right corner (shown at left) to keep the window pinned open. This allows you to audition multiple options before manually closing the window.
  • Picker windows include a Search field which helps you filter the list to find a desired entry. You can search on item names or numbers (number matching can be disabled in Settings | Preferences | Options as desired). You can also use ARROW KEYS to navigate and the ENTER key to make selections in a picker window.
  • The Cab Picker shows the names of UltraRes cabs in italics. Read more about UltraRes in the Blocks Guide.

Preferences

Prefs.png

You can set personal preferences for the editor in Settings | Preferences. Or Press ⌘+P (Mac) or CTRL+P (Win).

General menu

Ports: shows the input and output ports used by the editor. The program automatically selects the USB ports of a connected guitar processor, so you should not need to manually select ports. Note that port names refer to MIDI even when connected via USB.

Controls menu

  • Knob Mode: determines how knobs respond to mouse motion. Linear (default): the values of knob parameters increase as click and drag the mouse away from the center of the knob. Move up or to the right to increase, down or to the left to decrease. The fastest response occurs when you move in a “northeast” or “southwest” direction. Circular: the knob pointer follows your mouse pointer as you click and drag in a circular motion.
  • Mouse Wheel: typically, you won’t need to change this setting, but if the action of your touchpad or the wheel of a connected mouse/trackball seems backwards, change this value to Reverse. Or you can disable the wheel altogether.
  • Refresh Rate: controls the display refresh rate of block parameters, meters and graphs. Default is “Fast”.

Workspace menu

Snapshots: sets the location where Snapshot files are saved on disk.
Library: sets the root of the Library where blocks and channels are stored on disk. The editor monitors the root folder and all subfolders for valid entries (blocks and channels) to build the library.
Preset Templates: sets the location for loading and saving preset templates.
Global Settings: the editor stores its settings in this folder. It’s specific to the computer’s operating system and can’t be changed.

Refresh menu

Preset Names: updates the editor with the names of all presets stored in the guitar processor.
Cab Names: updates the editor with the names of all User Cabs stored in the guitar processor and and Scratchpad names.
Block Definitions: updates the editor with information about all blocks (block definitions) and all factory cab names. Block definitions are refreshed automatically when you install a new firmware version on the hardware. This option is for troubleshooting only.

Options menu

Automatically check for a new version at startup: at startup, the editor checks automatically if an official update for the editor is available and if so, offers the option to download and install the update. This setting lets you disable this process.
Show tooltips when the mouse hovers over buttons: this controls the display of tooltips when hovering over screen elements.
Search returns matches from number and name fields in picker windows: Picker windows include a Search field which helps you filter the list to find a desired entry. You can search on item names or numbers. This behavior can be changed here.
Warn about making backups before Manage Presets or Cabs: by default, Manage Presets and Manage Cabs display a warning about making backups at startup. This setting lets you disable this.
Prompt on edited presets when changing or importing a preset from the editor: this setting enables or disables a safeguard against quitting or switching / importing presets without saving changes first.
Default to <All Banks> when launching the Cabinet Picker: this setting lets you choose your favorite startup option when launching the Cabinet Picker: display cabs from all Cab banks, or a single one.
Warn when editing the FC Master Layout Menu: the Master Layout Menu (MLM) is an important element of operating the foot switches on an FM3, FM9 or FC controller. This setting enables or disables a warning message when editing the MLM.
Default the Amp block to “Ideal” upon initial view: the Amplifier block can be displayed in Ideal or Authentic mode. In AUTHENTIC mode only the controls which are present on the modeled amp are displayed on the main page. In IDEAL mode all controls are displayed.
Refresh the Scratchpad names each time the CAB block is selected: when selecting a Cabinet block on the grid, the editor fetches the names of the Scratchpads from the guitar processor to ensure that the editor and the guitar processor are in sync. This setting allows you to disable this to speed operations.
Read the Preset names at startup: at startup, the editor fetches the names of all presets from the guitar processor to ensure that the editor and the guitar processor are in sync. This setting allows you to disable this to speed the launch process. When disabled, you can still refresh preset names manually by pressing the Refresh icon in the Preset Picker or the Manage Presets tool.
Read the User Cab names at startup: at startup, the editor fetches the names of all User Cabs from the guitar processor to ensure that the editor and the guitar processor are in sync. This setting allows you to disable this to speed the launch process. When disabled, you can still refresh the cab names manually by pressing the Refresh icon in the Cabinet Picker or the Manage Cabs tool.

Cabinet Import

IR Processing: the built-in (factory) cabs in the guitar processor are processed with proprietary minimum phase transformation (MPT) which guards against phase problems when you mix multiple cabs. This setting allows you to disable or enable MPT when importing external cabs (impulse responses), or when you prefer to use Auto Trim instead which removes superfluous silence from the start of the cab (without applying MPT).
IR Output: this setting determines the format of the user cab (impulse response) that’s created when importing an .ir or .wav file.
WAV Import: determines which channels are imported when stereo .WAV files are added to the Manage browser menu.

Other personal preferences which affect the editor can be set in the Setup menu. For example, select Setup | Config to be able to assign a custom name to your connected guitar processor.

Working with blocks

Manage blocks

Insert

  • Right-click (or Control+click on the Mac) any grid slot to bring up the Grid menu. Choose a block and it will be placed on the grid. Blocks already on the grid are shown as disabled in this menu. You can also select Insert on the top-level Block menu or press Quick Build.
  • A keyboard shortcut can be used to place “shunts”: ⌘+U (Mac) or CTRL+U (Win).
  • You can use the Grid menu to replace any block with another of a different type

Gridmenu.png Blockmenu.png


Delete

  • Select a block and press the DELETE (Win) or BACKSPACE (Mac) key on your keyboard. Or select Delete in the top-level Block menu or by selecting Grid menu | Edit.

Bypass / Engage

  • Double-click or select the block and press the SPACEBAR key. You can also click Bypass/Engage in the top-level Block menu or the Grid menu.
  • You can bypass or engage a block across ALL scenes at once, using a shortcut key listed near the end of this document.

Swap

  • Drag and drop one block onto another (or on a shunt) to swap their grid positions. All connections to and from each block will be preserved when you perform a swap.
  • Hold ⌘ (Mac) or CTRL (Win) while dragging/dropping to force a block to replace instead of swap.

Move

  • Drag a block to an empty grid space to move it.

Cut / Copy / Paste

  • Select a block and press a keyboard shortcut (also appears on the top-level Block menu or by selecting Grid menu | Edit):
    • Mac: ⌘+X / ⌘+C / ⌘+V
    • Windows: CTRL+X / CTRL+C / CTRL+V
  • You can copy/paste blocks across presets.
  • Copy a block, then select another block of the same type before pasting and all settings of the first block will be transferred to the second (Ex: DELAY 1 and DELAY 2).

Reset

  • Right-click a block and choose Edit | Reset Channel from the menu. Or select the block and press ⌘+I (Mac) or CTRL+I (Win) or choose Block menu | Reset Channel. This sets the parameters in the current channel to their default values.
  • Resetting applies to the current channel only. To reset an entire block (all channels) the reset has to be executed per channel.

Disconnect

  • Select a block and press ⌘+D (Mac) or CTRL+D (Win) to remove all connector cables from its input and output. Or select the equivalent command in the Block menu or Grid menu | Edit.
  • You can also drag a block to any empty grid slot in another column with the same effect.

Library: discussed later.

Select a Channel

  • Select a block’s channel by pressing A, B, C or D on the keyboard (or “X” for the next channel), or the bottom-left Channels dropdown menu, or in the top-level Block menu or in the Grid menu. The Channels dropdown menu also lets you copy and paste channels.

Left.png

Move row or column

  • Use the sliders at the bottom and left borders of the grid to move an entire row or column. Or select Block menu | Move.

Grid Navigation Mode

  • When working with blocks on the grid, the editor will load data from the hardware device. If displaying the settings of blocks isn’t necessary, you can speed grid operations by enabling Grid Navigation Mode: press ⌘+SHIFT+G (Mac) or CTRL+SHIFT+G (Win). A border will appear around the grid. To quit Grid Navigation Mode, press Escape on your keyboard.

Quick Build

  • Pressing Quick Build (or press the “Q” key) lets you insert a block from a graphical list of blocks (example below).

Quickbuild.png

Connect blocks

Cables.png

The editor makes it easy to add and remove block connections.

  • When you select a block, notice that it displays Input and Output “Jacks” — small circular objects labeled “I” and “O”. These are used to create or remove connections to/ from the selected block.
  • When you click a jack, it becomes selected and all valid destination jacks are highlighted in green.
  • Click the desired jack, and the connection appears.
  • You can make connections in either direction, even spanning multiple columns as desired in a single click. Just as on the device itself, if you make a connection to the jack of an empty grid location, a shunt will be inserted automatically.
  • Destination jacks shown with a red X indicate that an existing connection can be removed.
  • Click the red “X” and a connection will be removed.

Tips:

  • You can double-click any existing connection to remove it instantly.
  • To connect across an entire row, connect the output of the first block to the input of the last block.

Edit blocks

When a grid block is selected, its parameters are shown below the grid in the editor. The editor section will have a different number of “pages,” in vertical order.

With Grid Navigation Mode enabled (see above), the parameters of blocks will not be fetched and displayed (to speed things), but you can still change the positions of blocks on the grid. Press ⌘+SHIFT+G (Mac) or CTRL+SHIFT+G (Win) to enable Grid Navigation Mode and Escape to quit.

Channels

Channels give most block types four fully independent sets of parameter values that can be used to toggle sound changes at will. It works like the “channels” of an amp or some pedals.

Click the ABCD control in the editor to select the desired channel. Remember that the active channel can be set differently for each SCENE within a preset.

Click on the dropdown menu for copy and paste options. You can copy/paste states between blocks of the same type, even across presets. The channel can also be toggled in the Grid menu and the top-level Block menu, and by simply pressing the A, B, C, or D key on your keyboard, or X for next channel. You also reset a channel and set a block to a specific channel across all scenes in the Block menu.

Some of these actions can also be accomplished in the dedicated Scene Manager tool.

Left.png Scenemgr.png

Library

About the library

The Library is one of the most powerful features of the editor. It allows you to create a library on disk containing your favorite settings. A block or channel saved in the Library includes all parameter settings for all four channels of the block or just a single channel plus modifier assignments.

Note: this used to be called Block Library. These days it's just "Library" because the library can also contain stored channels.

To use the Library, you might dial in a Delay block and then save it as “My No.1 Delay”. Then, when working later in another preset, you could recall the saved block and all its settings with just a few clicks.

It's important to note that when you recall a block or channel from the Library, it does NOT have a connection (no dynamic link) to the master copy on your computer.

Block and channel files are interchangeable between the editors for the various guitar processors (current generation). Parameters which are not supported by a specific guitar processor are ignored.

Working with the library

There are multiple ways to save blocks and channels to the Library. The easiest is perhaps the Library control which appears in the lower left corner of the editor whenever a block is selected. Click on the arrow and choose Save. Name the block or channel, choose between saving just the channel or the entire block, press Save and you will have created a new entry!

Library.png

You can also press the keyboard shortcut (Mac: ⌘+B, Win: CTRL+B) or select the Library from the Block menu or the Grid menu.

Once you’ve recalled a block (see below) you can make and save changes, or use Save As... to create a totally new entry from the current settings. You can rename or delete an entry, or force the editor to re-read all data from disk.

Selecting Preset | Save as Blocks in Library lets you export all blocks for the current preset to the Library folder with a single command. The blocks are saved in a timestamped directory with the format YYYYMMDD-HHMMSS ("20210709-093339", for example), under which will be folders for each preset. You need to provide a name (unique within the category) whenever you save a new library entry.

Tip: When naming, keep in mind that the library is organized by type. For example, if you were saving Multidelay block settings as “Shimmer”, you could simply call it “Shimmer” instead of “Multidelay Shimmer”.

Blocks are saved as individual .blk files to your computer in: ~/Documents/Fractal Audio/(name editor)/Blocks . You can change the location of this directory in Settings | Preferences | Workspace. You can rename a .blk file on disk, but this won’t change its name in the Library.

To recall an entry from the Library, use the Library control, the Block menu or the Grid menu. You can also drag and drop a .blk file from your computer into the editor’s grid.

Library blocks are completely interchangeable with any numbered instance of the block. For example: You can save “FILTER 1” and recall it as “FILTER 1”, “FILTER 2”, “FILTER 3” or “FILTER 4”.

You can use your operating systems’ file management to manage items in your Library (or share them with other owners). Entries are automatically organized in subfolders by type (AMP, CAB, DELAY, etc.) but this is for only for your convenience as the editor will recognize all valid files found anywhere below the Library folder.

Share a library between editors

The latest generation of hardware (FM3, FM9 and the Axe-Fx III) can share libraries. Where minor technical inconsistencies exist between blocks, the editors do a good job of interpolation and making them work across the devices.

To best take advantage of this, you need to configure each of your editors to point to shared folders for holding blocks and other things. You do this in Settings | Preferences | Workspace.

Export a block for sharing

Here are instructions for exporting a single block file for sharing in something like the The Mother of All Effects Thread.

Select the block you want to save settings for in the grid area of the editor. With the block selected, in the lower left corner of the editor you will see the block library management area for the block. It has the header Library -- it should be quite obvious.

Press the down arrow next to the Library header to bring up the library management menu. Select the Save option from the menu. You'll be presented with a dialog box. Name the block settings something descriptive. Whatever you enter here for the name of the block is what you'll see in the library selection dialog in the editor. You can also chose to save just the settings for a single channel (which can then later be loaded back into any channel on a block) or all the channels for the block. Once you've named your block and picked your save option, press the Save button. The block is now saved to disk.

To find the file that was created, press the down arrow next to the Library header once again and select Show Folder from the menu. A system folder dialog will open to the exact location where the block files are being saved for this effect block type.

You can use whatever mechanism you like to share this .blk file. For example, the forum allows you to drag these files into posts where it attaches them to the post for others to download.

Import a shared .blk file

You can bring .blk files shared by others into your editor so you can create instances of that block with shared, saved settings in your own presets. You'll need to know the path where your editor is looking for block settings and can find this using the Preferences... > Workspace menu on the editor. Download the .blk file to your computer. Using your computer's file browser, locate the downloaded .blk file on disk. Copy that file from the download location to the location where your editor is looking for block files.

You don't need to put the file in a subfolder, but it is advantageous if you have a lot of block files saved to organize things into subfolders. By default the editor will create a subfolder for each effect block type when saving settings, i.e., Chorus blocks will have their settings saved into a Chorus subfolder.

When the editor scans for block settings it scans the entire folder tree starting from the Library setting you tell it to look in. This lets you organize block files in any way that makes sense to you, with as much subfolder hierarchy as you like.

For example, forumite iaresee likes to create a subfolder named after the forumite who shared the block settings and then, under there, a folder named after the block. This lets him remember who created the settings in addition to what block the settings apply to (and conveniently, the block file names already include the date and time stamp by default in their file name).

Example:

Editor/
    blocks/
        austinbuddy/
            Flanger/
                Deluxe Electric Mistress_20190513_231434.blk
        fremen/
            Amp/
                fremen ultra-clean_20210501_231434.blk
        Chorus/
            Standard Chorii_20210616_204455.blk

Note, after you've saved a block file to your folder you need to refresh the block settings in the editor. You can do this by selecting any block in the grid, pressing the down arrow next to the Library header, and selecting Refresh Library from the menu. The editor will rescan _all_ the block settings for _all_ the blocks found under the library path.

Forumite Leon Todd's (2112) video Tuesday Tone Tip - Blocks & Channels Library briefly discusses importing an entire library of blocks.

Global Blocks

Axe-Edit III includes full support for Global Blocks, a feature found exclusively on the Axe-Fx. All operations are all supported through the Global Blocks control in the bottom-left corner of the editor.

Press Block Info, or hold ALT (Win) or Option (Mac), to see which blocks on the grid are Global Blocks.

Select Preset | Unlink All Links from Global to unlink all global blocks in the current preset, which is handy when sharing a preset or when creating backups.

For more information about Global Blocks, check the Owner’s Manual.

Globalblocks.png

Working with scenes

Scenes provide every preset with 8 sets of saved settings for a limited set of parameters:

  • Bypass State of every block in the preset
  • Channel of every block in the preset
  • Scene levels in every Output block in the preset
  • Scene Controllers settings
  • Scene MIDI block settings
  • Control switches state
  • Scene name

All other parameter settings remain the same across all scenes in your preset.

Select
To select a scene in the editor, simply press one of the Scene buttons at the top. You can also hold ⌘ (Mac) or CTRL (Win) and press any scene’s number on your keyboard for direct selection. Or click on Scene 1-8 below the grid, shown after loading a preset or when selecting an empty block on the grid.

Scene3.png Scene2.png

Scenes dropdown menu
The Scenes dropdown menu provides handy options, such as copy/paste, swapping, engaging or bypassing all blocks. Note: The clipboard for scenes is cleared when you change presets or “revert” the current preset.

Scene1.png

Rename
To rename a scene, click and edit the scene name at the top, or double-click the scene name below the grid (displayed after loading a preset or when selecting an empty block on the grid).

Scene Manager
Many of these actions can be also accomplished in the dedicated Scene Manager tool.

Scenemgr.png

The Scene Revert setting in the guitar processor’s own MIDI/Remote menu is ignored when switching scenes in the editor. So, if you change the bypass states of blocks and use the editor to switch to other scenes and then return to the earlier scene, those blocks’ bypass states will still be the same (not reverted to their initial stored states).

Working with presets

Preset menu

Commands in the Preset menu:

Revert Preset: discards all changes and reverts to the last saved version of the preset.

Clear Preset: removes all blocks and clears the preset name. A warning will be displayed first.

Unlink All Blocks from Global: see the section about Global Blocks. A warning will be displayed first.

Save Preset: saves the preset, the same action as pressing the Save button.

Save to New Preset Number: saves the current preset to any memory location in the guitar processor.

Save Snapshot: see the section about Snapshots.

Save All Blocks in Library: see the section about the Library.

Import Preset: see the section about importing presets.

Export Preset: see the section about exporting presets.

Export Preset+Cab Bundle: see above.

New from Template: see the section about preset templates.

Save as Template: see the section about preset templates.

Recent Presets: quickly recall one of the last 10 presets you were working on.

The Tools menu also provides handy stuff. Get information about MIDI SysEx files through Get Sysex File Information. Select Tools | Export As Text to generate handy lists (see picture).


Exportmenu.png

Load

In addition to loading presets from the guitar processor itself, you can also import (load) individual presets from disk. This allows you to load files you’ve backed up, downloaded, or saved as Snapshots.

Choose Preset | Import to display a file browser dialog. Or press CONTROL+SHIFT+⌘+I (Mac) or CTRL+SHIFT+ALT+I (Win). Navigate to a folder, select any valid preset SysEx (.syx) file for your guitar processor and open the file. The preset is instantly imported to both the guitar processor itself (buffer) and the editor, so you can audition and edit as desired. You can also drag and drop a preset file from your computer onto the preset area of the editor.

Imported presets are NOT stored in the guitar processor until you manually save the preset!

You can also open a saved Bank file (.bnk) and import a single preset from that bank (a bank file contains up to 127 presets). The process is the same.

Select Preset | Recent Presets to quickly return load one of the last 10 presets you’ve saved or loaded.

Tip: “Pin” the picker window and you can audition presets before importing one.

Save

As on the hardware, you will be notified of any unsaved changes to the preset by the yellow Edited LED in the Save button.

Click Preset | Save Preset, or press ⌘+S (Mac) or CTRL+S (Win), to save the current preset to the current preset slot in the guitar processor.

Click Preset | Save to New Preset Number, or press ⌘+SHIFT+S (Mac) or CTRL+SHIFT+S (Win), to save the current preset to another memory location in the guitar processor.

As a safeguard, the editor displays a warning when quitting or when changing / importing a preset without saving the changes first. You can disable this in Settings | Preferences | Options.

You can specify in Setup | Config whether switching scenes should be marked as “Edited” or not.

Export

Exporting presets allows you to save backup copies on disk, share them with others, post them on our preset sharing site Axe-Change, etc.

To export the current preset as a SysEx (.syx) file on your computer, choose Preset | Export. Or press CONTROL+SHIFT+⌘+X (Mac) or CTRL+SHIFT+ALT+X (Win). When the file browser dialog is shown, navigate to the desired location and save the preset.

Presets may include Global Blocks. Exporting a preset does NOT include the linked global data. To share the linked global data, you need to back up your System data with Fractal-Bot and include that data with the preset. Or you can unlink the Global Blocks in the preset through Preset | Unlink All Links from Global before exporting.

Exporting presets can also be accomplished in Manage Presets. When exporting from Manage Presets, the preset number will be added to the start of the filenames on disk and the preset title.

Preset+Cab bundle

A Preset+Cab bundle contains one preset plus any User Cab Impulse Responses (IRs) used by that preset. Bundles make it easier to share sounds and are easy to export and import.

To export a Bundle, select Preset | Export Preset-Cab Bundle. IRs that this preset refers to but does not use are excluded but can be included manually by checking them. Examples include cabs that are muted or channels that are not referred to by any scene. Factory cabs cannot be exported/checked.

To import a bundle, select Presets | Import Preset, or drag-and-drop a bundle file onto the editor's main Preset display. To proceed, you must select a location. The preset will be updated automatically to refer to the location(s) you selected for the cab(s).

New from template

Like many other types of programs (office, graphics, etc.) the editor allows you to create new presets from a template. Choose Preset | New from Template. The “working copy” is not the original template. When you save, you’ll be storing a preset in the guitar processor while the template file on your computer will remain unmodified.

Templates are stored in a dedicated directory. The default location is: ~/Documents/Fractal Audio/(name editor)/Presets/Templates You can change the location of the Templates directory in Settings | Preferences | Workspace.

Create new templates using Preset | Save as Template, or by copying exported or downloaded preset files to your Templates directory. Use the operating system’s file management to delete or rename templates, but remember that the file name is independent of the name stored in the template.

Snapshots

Snapshots.png

Snapshots provide one-click export to disk functionality. This is especially handy for fast backups during editing.

When you press the Snapshot button, or press CONTROL+SHIFT+⌘+S (Mac) or CTRL+SHIFT+ALT+S (Win), a copy of your current preset (including unsaved changes) is saved as a file to the Snapshots folder on your computer: ~/Documents/Fractal Audio/(name editor)/Presets/Snapshots

You can change the location of the Snapshots directory in Settings | Preferences | Workspace. An on-screen indicator confirms that the snapshot has been saved.

Previous snapshots can be brought into the editor using Preset | Import or by selecting the dropdown menu below the Snapshot button.

Presets may include Global Blocks. Pressing Snapshot will create a backup of the preset but the linked global data will not be saved with the snapshot.

Cross-compatibility

The Axe-Fx III, FM3 and FM9 guitar processors each use their own specific SysEx (.syx) file format for presets. However, each editor can load preset files created on the other devices and convert where necessary and possible. This conversion includes:

  • Adapting the preset to the grid size of the connected guitar processor, and fit the blocks in the preset on the grid
  • Leaving out blocks which aren’t supported by the connected guitar processor (replaced with a shunt)
  • Displaying a warning CPU Limit - Muted when there’s not enough CPU power to handle all blocks
  • Leaving out features and functionality which aren’t supported by the connected guitar processor.

Leveling presets

This tool in the Tools menu lets you monitor the level of the current preset, and provides parameters to adjust the level. This is handy when matching preset levels. The tool can also be activated by pressing ⌘+L (Mac) or CTRL+L (Win). The meters displayed are the same as the VU meters on the zoomed-out Layout Grid on the hardware itself.

Read more about leveling in in the Owner’s Manual.

Leveling.png

Filter by color

The Preset picker and Cab picker windows let you assign a color to entries, thus creating categories and marking personal favorites.

Filtercolor.png

Tools

Fractal-Bot

Read more about Fractal-Bot. It's available as a standalone program, or as a built-in tool in the editors.

Manage Presets and Manage Cabs

Managetool.png

The editor’s Manage Presets and Manage Cabs tools allow you to rearrange, delete, move, swap, duplicate, rename and more. Select Tools | Manage Presets or Tools | Manage Cabs. Or press ⌘+M (Mac) or CTRL-M (Win) for Manage Presets, or ⌘+SHIFT+M (Mac) or CTRL+SHIFT+M (Win) for Manage Cabs.

SAVE any unsaved changes first!

The interface should feel familiar as it is based on the “picker” view used to select presets, amps, tempos, etc. The tools can also be launched from within the Preset Picker and Cab Picker.

Note that these tools have two panes. If the left pane (Browser) doesn’t appear, ensure that it is enabled in the Browser menu or click the button next to the menu, or use the key sequence CTRL+B (Win) or ⌘+B (Mac). If it is enabled but still not clearly visible, look for the vertical divider and drag it to the right.

By default, Manage Presets and Manage Cabs display a warning about making backups at startup. This can be disabled in Settings | Preferences | Options.

Note: The Manage Cabs tool shows the names of UltraRes impulse responses (cabs) in italics. Read more about UltraRes in the Owner’s Manual.

Refresh names
The Refresh button forces Manage Presets or Manage Cabs to fetch the names of all presets or user cabs from the guitar processor. This ensures that the data is synced.

Select

  • To select a single entry (or undo): Click any preset or cab.
  • To select a range (or undo): Click any preset or cab, hold SHIFT and then click another preset or cab.
  • To select multiple individual presets or cabs in any location (or undo): Hold ⌘ (Mac) or CTRL (Win) key and click multiple presets or cabs.
  • To select ALL presets or cabs: Press ⌘+A (Mac) or CTRL+A (Win).

Browser menu
The Browser menu lets you configure the use of Manage Presets and Manage Cabs.

Context menu
Right-click or Control-click on a Preset or Cab to select actions for the selected entry.

Reset AMP blocks
This is a special command in the context menu. It will reset ALL channels of all Amplifier blocks in the selected preset, while maintaining the settings on the Authentic page of the Amplifier blocks, and automatically will SAVE the preset too. It can be applied to multiple presets at once.

Drag and drop
Manage Presets and Manage Cabs support drag-and-drop operations. When you drag and drop one or more selected items, they will be swapped with those in the target location. If you hold ⌘ (Mac) or CTRL (Win), they will be moved (leaving one or more empty locations). If you hold the SHIFT key, the selected items will be copied.

You can also drag and drop presets or cabs from your computer into Manage Presets or Manage Cabs.

Save changes
Manage Presets and Manage Cabs wait to apply changes until you press the SAVE button. This is both a safety mechanism and an efficiency feature. As unsaved changes are made, the affected entries turn red and are marked with a red dot. Press the SAVE button to commit changes permanently. Press the CLOSE button to quit without saving. Saved changes turn green and the dot is removed.

Performance pages

The Performance pages on the guitar processors let you quickly change sound settings during a performance.

The editor lets you customize these pages to your personal preferences. You can define a Global Performance page, and Per-Preset pages.

Click Perform, and drag and drop controls from the currently selected block onto the left or right pane. To delete a control from a pane, press Delete on your keyboard. To switch blocks, use the dropdown menu (arrow) at the top-left of the lower pane.

More information about Perform pages

Tip: copy your favorite global Performance controls to a preset as Per-Preset controls. This will let you easily restore the global controls from that preset after a system reset (a system reset deletes the Global Performance controls).

Performp.png

IR Capture

The Axe-Fx III lets you capture impulse responses. This can be accomplished through the user interface on the guitar processor itself or through Tools | IR Capture in the editor. More information about IR Capture

IRcap.png

Axe-Change

Axe-Change is the official preset and cab sharing resource for Fractal Audio Systems’ guitar processors. It’s accessible under the Tools menu where you can load presets and cabs directly from Axe-Change into the editor. You can also visit Axe-Change with your web browser.

Axechangewindow.png

Working with the FC controllers

Configure an FC

The FM3, the FM9, and the FC-6 and FC-12 foot controllers from Fractal Audio Systems let you control your guitar processors using your feet. Press FC Edit and FC Per-Preset in the editor for configuration options. Read more about the FC controllers.

Tips:

  • Go to Settings | Preferences | Options to enable or disable a warning when editing the FC controller’s Master Layout Menu.
  • Press the 10 button to mask characters in Preset and Scene names that do not fit on the scribble strips of the foot switches.

Songs and setlists

Current firmware for the Axe-Fx III and FC controllers let you create and manage songs and setlists. This can be done on the hardware or in Axe-Edit III. Read more about songs and setlists.

FC-126side-by-side.jpg

Keyboard shortcuts

Presets
Preset Manager = Command/Control + M
Preset Picker = P
Preset up/down = Command/Control + PgUp / PgDn (on a MacBook: hold Fn too)
Refresh preset = F5
Save preset = Command/Control + S
Save preset to new preset number = Shift + Command/Control + S
Revert preset = Shift + Command/Control + F12
Clear preset = Shift + Command/Control + Backspace
Save snapshot = Shift + Control (Alt) + Command/Control + S
Import preset = Shift + Control (Alt) + Command/Control + I
Export preset = Shift + Control (Alt) + Command/Control + X

Scenes
Select a scene = Command/Control + 1/2/3/4/5/6/7/8

Blocks
Show Block Info = Alt or F1
Show Quick Build panel = Q
Insert a shunt = Command/Control + U
Bypass or engage the selected block, or toggle X/Y (old editors) = Spacebar
Set state of block across all scenes to engage = Shift + Spacebar
Set state of block across all scenes to bypass = Shift + Command/Control + Spacebar
Disconnect all cables from selected block = Command/Control + D
Delete block = Backspace
Open the Edit field of the selected control = Enter
Display the menu associated with the ‘+’ button on the selected dropdown control = +
Toggle the “Global” button for the selected control = G
Value up/down = cursor up/down
Save block to Block Library = Command/Control + B

Channels
Select channel (E and F apply to the MUX block only) = A/B/C/D/E/F
Next channel = X
Reset channel = Command/Control + I

Tuner
Command/Control + T

Devices Show devices = Command/Control + K

Communications
F8: pause communications

Preferences
Command/Control + P

Undo, Redo
Undo = Command/Control + Z
Redo = Command/Control + Y
Cut, copy, paste = Command/Control + X/C/V

Preset Manager, Cab Manager
Manage Presets = Command/Control + M
Manage Cabs = Shift + Command/Control + M

Grid Navigation Mode
Shift + Command/Control + G

Window size
Full screen = Shift + Command/Control + W
Normal size = Shift + W

FAQ

The editor won’t change presets, or changes presets erratically

Verify that Preset Mapping isn’t enabled on the guitar processor’s MIDI/Remote menu.

The tuner won’t work

Ensure that the tuner on the guitar processor is set to page 1 (tuner display).

How do I back up or restore Preset Banks?

Use Fractal-Bot. Fractal-Bot is available as a standalone application or in the editor’s Tools menu.

How do I update the firmware of my guitar processor?

Use Fractal-Bot to update the firmware. Fractal-Bot is available as a standalone application or in the editor’s Tools menu. When launched, Fractal-Bot checks for official updates and when available: provides the option to download and install an update.

Typing values doesn’t work for MIN and MAX fields on the modifier screen

This is a limitation of how the editor works with the hardware. It only affects MIN and MAX on the modifier screen.

When I double-click a parameter, it is set to a generic default value, which may not be the same value as when resetting a channel or the entire block. Why?

It is a limitation of the architecture at this time.

Can I use the editor to create and edit presets, without being connected to the guitar processor?

The editor works in tandem with the hardware unit in a client-server type relationship. The editor requires the unit to be connected for all operations. Offline editing is not supported and will NOT be added to future versions. The client-server relationship brings a host of benefits to the editor. Most importantly, it can never corrupt a preset as only the hardware itself ever owns the data. This means you can program sounds with the confidence that what you see is what you'll hear is what you'll save.

I have an issue with resizing the editor’s window. How do I solve this?

Close the editor, delete its settings file, and restart the editor. The settings file is found in:
Windows: C:\Users\<user name>\AppData\Roaming\Fractal Audio\(editor name)
Mac OS X: <user name>/Library/Application Support/Fractal Audio/(editor name)

Are iOS and Android versions of the editors available?

So far, such versions of the editor have not been released.

My computer doesn’t have a touchscreen. How can I still use the editor with a touchscreen?

Connect a tablet to your computer and use the operating system’s built-in support for displaying a second screen or a third-party solution.