How to download/upload patches

From Fractal Audio Systems Wiki
Jump to: navigation, search

Uploading/downloading with the editor

Downloading Axe-Change patches using Axe-Edit

  • Go to Preset Manager in Axe-Edit.
  • Go to the Axe-Change tab (right window) and press "Source" button. You will need to create an id to login with. It can be any id not previously used by Axe-Change. It is NOT (automatically) your forum ID + password - but can be if you want to use that and it is available. Note that this is a completely separate FAS system and not linked to the Forum. BTW - Preset Manager DOES remember the id and password you use next time you login.
 URL = http://brains2bits.com/cgi-bin/axechange/
 user: your choice
 pass: your choice
  • Click "Login/Create" button and if your id/pass combo is valid you should be presented with a "login confirmation" box.
  • Now press "Load". You can "Load All Banks" or load an individual bank. This will download all patches from AxeChange to your local machine or only the contents of that selected bank. The speed at which this happens depends on your internet connection speed, but WILL take a few mins to complete. Watch the progress bar on the bottom of the pane. You can navigate thru the banks.. most recent is Bank "J" (at this writing). Higher than J are empty. There's 1221+ patches in there so far.

+ You may save ALL these patches to bank files stored on your PC for future use. That way you only need to update the most recent banks on future connections. Here's how to do this:

  • Select Bank "A" then click "Save" button... "Save Bank As.." "Bank File".
  • Chose the save location. I keep mine in a folder called AxeChange under my main FractalAudio\Patches directory.
  • Name the bank file something meaningful like Axe-change_Bank_A.syx
  • Click "Save" button.
  • Repeat save process for bank B thru J.

You can now pull these up in the left pane under the Presets tab, or in the main AxeEdit window by selecting "Bank File" under the source button. You can edit, audition, and save to the Axe from there. Remember that anything you save to the Axe OVERWRITES whatever was previously in that location, so make sure you do a backup of all your banks before you start "playing" with patches.

Uploading a patch with the editor

To upload a patch you created to Axechange, follow these steps:

  • If you haven't already, create an Axechange account
  • Open the editor
  • Configure your Axechange account settings (Options -> Configure Axechange Account)
  • Load the patch you want to upload into the main editor window
  • Click the "Upload to Axechng" button (fourth from the right, just over the matrix)
  • Add a description of what the preset is and set the appropriate options below
  • If you have an MP3 clip on the web, type the URL into the "Link (optional)" field
  • Click the "Upload" button
  • You will get a message saying "Preset successfully uploaded to Axechange!" to confirm everything worked.

Downloading a bank with the editor

To download a bank from the Axe-Fx:

  • Open the editor
  • Select File -> Download Bank from Axe-FX
  • Select which bank you want to grab from your Axe-Fx
  • Hit "OK"
  • The editor will automatically command your Axe-Fx to send the appropriate bank
  • When completed, save the bank via File -> Save As

Uploading a bank with the editor

NOTE: This will overwrite any patches you have saved in a given bank on your Axe-Fx!

To upload a bank to the Axe-Fx:

  • Download the bank(s) from Fractal Audio or from the presets page
  • Open the editor
  • Open the bank you want to upload into the editor (File -> Open)
  • Select File -> Upload Bank to Axe-FX
  • Select which bank on the Axe-Fx you want to put the bank into
  • Hit "OK"
  • The editor will send your Axe-Fx the bank

Uploading and Downloading Patches without using the Axe-Editor

You can use software that sends and receives MIDI system exclusive messages to download and save patches and banks to your hard drive and restore them to your Axe-Fx. When downloading a bank or patch from your Axe-Fx you need to tell the software to capture the system exclusive messages to a file. When uploading from a file on your hard drive, to the Axe-Fx, simply sending the system exclusive messages will cause the Axe-Fx to update itself. It recognizes the incoming patch or bank stream and just does the right thing.

Uploading a saved bank file from your computer to the Axe-Fx will completely replace that bank in your Axe-Fx with the contents on the file. There is no confirmation dialog or undo. So exercise caution.

When uploading a saved patch file from your computer to the Axe-Fx the current edit buffer is replaced with the contents of the patch file and the edit light on the front of the unit will be lit. You can choose to save the patch to the unit using the Save button on the front of the Axe-Fx.

--Iaresee 16:06, 21 July 2009 (UTC)

Instructions for Windows Users

Setting up The Software

  • Download MIDI-OX if you dont already have it: MIDI-OX
  • Start MIDI-OX and use Options -> MIDI Devices to select your MIDI device input/output (this might pop up automatically the first time you run MIDI-OX)
  • Open the sysex window View -> Sysex...

Another (and much easier to use) MIDI librarian you can use is Bome's SendSX.

Saving Banks and Patches

  • Select Sysex -> Receive manual dump to start listening for a sysex dump
  • On the Axe-Fx: press the Utility button, and use the Page button to navigate to the Preset page.
  • On the Axe-Fx:
    • To dump an entire bank select one of the Dump Bank (A|B|C) options from the list and press the Enter to start the dump
    • To dump the current active patch select Dump Preset to MIDI and press Enter to start the dump
  • MIDI-OX will now receive the data and you can use Display Window -> Save as... to save the contents of the window to a .syx file on your computer's disk.

Restoring Banks and Patches

  • In MIDI-OX: "Command Window -> Load file..." and select an existing .syx file on your computer
  • In MIDI-OX: "Command Windows -> Send Sysex".

Instructions for OS X Users

Setting up The Software

  • Download SysEx Librarian if you dont already have it: SysEx Librarian
  • Start SysEx Library and use the pull down at the top of the Window to select your MIDI device for input and output

Saving Banks and Patches

  • Press the Record One button in the SysEx Library window. SysEx Library will pop up a dialog saying it's waiting for a system exclusive message to be recieved.
  • On the Axe-Fx:
    • To dump an entire bank select one of the Dump Bank (A|B|C) options from the list and press the Enter to start the dump
    • To dump the current active patch select Dump Preset to MIDI and press Enter to start the dump
  • SysEx Librarian will save the dump in its file list as Untitled. Select the file in the list and from the menu bar select File -> Change Name (note: I'm not 100% certain this is the menu option, I'll update it tonight when I'm in front of my Mac) and change the name of the file to something descriptive.
    • Example: I call bank dumps something descriptive that helps me identify which bank and when I did the dump: Bank A Backup - 02/29/2009.syx
    • Ending the file in .syx isn't strictly necessary but can help you identify the file later and is useful if you're going to share the patch with non-OS X users.

Restoring Banks and Patches

  • In SysEx Librarian: Double clicking on any file in the SysEx File list will automatically cause the file's contents to be sent to the MIDI out. The Axe-Fx will automatically receive a bank or patch file sent this way.

Mac How

Restoring a Saved Bank to a Different Bank Location

When you dump the entire contents of a bank from the Axe-Fx to your computer the bank location is saved as part of the dumped system exclusive messages. When you restore that bank to the Axe-Fx it will overwrite the same bank in the unit, no questions asked.

If you'd like to restore a saved bank file to 'different' bank than the one it came from you'll need to edit the system exclusive file contents to change the bank location in the file before sending it to the Axe-Fx. This method is handy for moving and entire bank's worth of patches from one bank to another.

For details on how to change the bank location stored in the sysex file see: MIDI_Tips#Changing_Bank_Location

--Iaresee 16:35, 21 July 2009 (UTC)