Editors: Axe-Edit, AX8-Edit, FX8-Edit

From Axe-Fx II Wiki

Jump to: navigation, search

The information on this page supplements the official manuals.

Axe-Edit.png

Contents

Axe-Edit, AX8-Edit and FX8-Edit

These are the software editors for the Axe-Fx II, AX8 and FX8. Available for Windows and Mac.

Download them here.

Refresh definitions after firmware update

The editor will recognize when the firmware on the unit has been updated and will refresh the effect block definitions. New firmware features may require downloading and installing a new version of the editor.

The editor is suitable for updating firmware on hardware. You need to use Fractal-Bot to update firmware.

Connecting

No offline editing

The editor works in tandem with the hardware unit in a client-server type relationship. The editor requires the unit to be connected for all operations. "Offline editing" is not supported and will not be added to any future version. The client-server relationship brings a host of benefits to the editor, most importantly, it can never "corrupt" a preset as only the hardware itself ever "owns" the data. This means you can program sounds with the confidence that what you see is what you'll hear is what you'll save.

The editor can be used with the hardware via USB, without requiring a 3rd-party MIDI Interface or driver (FX8 and AX8). The Axe-Fx II requires you to install a USB host driver first, and USB Adapter Mode must be disabled because this will slow down Axe-Edit.

AX8-Edit and FX8-Edit: only USB, not MIDI

AX8-Edit and FX8-Edit require an USB connection. They do not function through MIDI.

Google Chrome causes connection issue

Fractal Audio:

Solve communication time-outs and disconnecting issues

More information in the Getting Started Guide.

Edit on a tablet or smartphone

Read this: Editing on a tablet or smartphone.

Syncing with front/top panel and foot controller changes

It's recommended to not use the MFC-101 while Axe-Edit is running. Axe-­Edit relies on intensive two-­way communication which can cause audio gaps or stutters while using a connected MIDI foot controller.

The PAUSE COMMUNICATIONS feature, also available through an icon in the upper left corner or in the Settings menu, puts Axe-Edit on hold so you can test performance without glitches.

Engaging and bypassing effects on the MFC-101 does not update Axe-Edit. To make the editor recognize such changes, its polling mechanism must be engaged. This can be accomplished by attaching the Bypass parameter of any block in the preset to a controller. The block doesn't have to be connected to anything on the grid so use a low CPU block.

Noteworthy stuff

Keyboard shortcuts

More shortcuts in the Getting Started Guide.

Presets

Share presets across hardware devices

Presets can't be shared between the different kinds of hardware, they are not compatible. Effect blocks however can be shared through the Block Library.

FracTool can be used to load AX8 presets into an Axe-Fx II and vice versa.

Axe-Change

The editors support integration of Axe-Change, the facility that lets you share presets, IRs, and effect blocks.

Export to disk

To export a preset to disk for archiving or sharing, use the File menu. Select File -> Export Preset... and you'll be shown a standard file save dialog box to pick the disk, location and file name of the exported preset files. Presets are exported with a .syx file extension to indicate that they are in the System Exclusive MIDI file format.

Global Blocks can kept linked or get unlinked when exporting a preset. This is specified in Preferences.

Export to CSV

This command dumps the parameter data of the X and Y states of every block in a preset into a single CSV-file. This file can be opened with a program such as Excel or WinDiff.

You can use this feature to see if a preset has changed, by dumping a preset before and after a Reset command.

Current available as a menu command only in AX8-Edit. In Axe-Edit and FX8-Edit you can execute this command by holding down Ctrl+Alt+Shift and click Import (Mac: Command+Alt+Shift).

Import a preset

Importing a preset replaces the currently active preset buffer on the hardware with the contents of a preset file from disk. The results of the import aren't saved permanently to your unit until you hit the Save button in the editor. You must have your hardware connected and turned on for preset import.

To import a preset select File -> Import Preset... or use the Import button on the main window. A system file finder dialog will open and you use this to find a valid preset file on disk. Valid preset files generally end in .syx. Click the Open button in the dialog and the editor will overwrite the contents of the preset buffer in the hardware with the contents of the preset file.

If the file is corrupt or not a valid preset file, the editor will warn you and not send any of the preset data to the hardware.

Import from a preset bank

The editor lets you select presets from a bank file. Load the preset bank file through Import and use the Preset Picker.

To load an entire preset bank at once, use Fractal-Bot. Or use the Preset Manager Browser.

Preset Manager

The Preset Manager lets you import and export presets, rename them and copy/paste/move/swap them.

Clear, initialize, refresh or revert a preset

Cabs

Cab Manager

Axe-Edit and AX8-Edit include a Cab Manager which lets you import and export IRs, rename them and copy/paste/move/swap them. You can also use Fractal-Bot and Cab-Lab to load user cabs.

Scratchpad

Scratchpad is the name of the last user cab slots on the Axe-Fx II and AX8. Scratchpad contents are always cleared when cycling power. Use them as a handy tool to experiment with user cabs.

Cab-Lab features an one-click upload button to Scratchpad.

Create and load Preset-Cab bundles

Read this: Preset-Cab bundles.

Edit effects

Change a value with small incremental/decremental steps

Hold Command (Mac) or Ctrl (Windows) while changing a value with the mouse.

Delete a cable between blocks

Double-click the cable.

Edit a modifier and attach/detach controllers

Right-click a modifiable control.

Adjust Input Gate settings

Click on Input.

Adjust preset and scene levels

Click on Output.

Reset a block to its default settings

Select Edit > Initialize in the context menu. Or press Command+I (Mac) or Ctrl+I (Windows).

Note that resetting a block only applies to its current state (X or Y). To reset the entire block, perform the reset in X and Y.

Swap blocks

Drag a block onto another block.

Import and export internal controllers

You can save and load internal controller settings, such as Envelope, into a separate Controllers block. Click the Controllers button and use the Block menu.

When sharing a regular effect block with specific internal controller settings, distribute both the regular block and the Controllers block.

Manage Global Blocks (Axe-Edit only)

Use the Global Block widget in the bottom left corner of the Axe-Edit window.

Block Library

The Block Library lets you save and recall effects blocks. The block definitions are saved on your hard drive, giving you a near limitless amount of block combinations that you can store and pull from as you build your patches. You can even share block definitions with other users, and between Axe-Fx II, AX8 and FX8.

Saving a block definition saves everything about that block: the X and Y sets of the block as well as all scene states. The controllers assigned to the block are also saved but not the configuration of the specific controllers attached to the block. Note: X/Y support varies per Fractal Audio product.

Block files (.blk) should never be edited by hand. They contain checksum information that the editor uses to ensure they are valid block files and hand-editing the files will destroy their validity.

There are multiple ways to load a saved block definition into a patch:

You can find the Block Library in the Block menu, the Grid context menu (right-click) and the Block Library control when any amp, cab, or effect block is selected on the grid.

The editor saves blocks to folders under /Fractal Audio/(editor) /blocks/. Files anywhere in this directory will be read into the library based on their type. The directory structure is ignored. You use a single folder to store block files from different devices. Don't worry if there are no subfolders under the /Blocks folder on your computer. It will be automatically created by the editor after dropping a BLK file in the /Blocks folder and restarting the editor, or after saving a block in the editor. If there's no Blocks folder either, saving a block in will create it.

Blocks files are saved to disk with a name and a date-stamp (similar to snapshots). The name of the file is not the name of the block as it appears in the editor. Changing the file name will not change the block library name. The block library name is internally stored and can only be changed through the editor. Blocks must be given a unique name per effect-type. For instance, one cannot create two Amp block entries with the name “Killer Tone”. Block names may be reused across effect types, however. An AMP and a CAB block could each be named “Great Tone”.\* Upon reading the blocks from disk, if a block currently being read has a name that is in use in the library for the given effect-type, then that block being read will have its name appended with a number. The original file will remain unchanged. For instance, if two Amp blocks have name “Great Tone”, then the first read library entry will be “Great Tone” and the second read library entry will be “Great Tone(1)”, and so on. This enables you to share library block files without having to worry about naming.

Deleting a library block entry from the Block Library widget will also delete the file from disk.

"Save Preset As Blocks": this command is available in all editors and lets you store a preset as individual blocks. You use these blocks on other Fractal Audio devices through their editors. This includes sharing blocks between the various Axe-Fx II models, facilitating the migration of Axe-Fx II XL and XL+ sounds to Axe-Fx II Mk I/II. NOTE: the Axe-Fx II Mk I/II does not support X/Y switching for the Compressor, Gate/Expander, Graphic EQ, Mixer, Parametric EQ, or Tremolo/Panner blocks. Importing the aforementioned blocks into an Axe-Fx II Mk I/II will only import the X settings.

X/Y

Copy X or Y values from a block

Right-click X or Y and select the corresponding command.

Swap X and Y settings

Right-click X or Y and select the corresponding command.

Quick-toggle between X and Y

The X and Y sets are a perfect way to do quick A/B comparisons on changes. Copy X to Y in the editor, start tweaking on the Y side of the block (or vice versa), press X for a quick comparison.

Snapshots

The Snapshot button, located to the right of the Save button on the main editor window and inscribed with a small camera icon on it, allows you to quickly save a snapshot of the current state of the preset. This is a handy "quick save" button that you can employ while working on a preset to save the state of the preset mid-edit, so you can return to it later or call it up for comparison. Snap shots are saved to a standard location and the files are labeled with the name of the preset, followed by the date and time of the snapshot, so that every preset save is a unique file and ordered in time.

Personal tools
Namespaces
Variants
Actions
Navigation
Wiki sections
Contributing
Toolbox